summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f25015ca4d57
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+#Maintainer Reto <reto@labrat.space>
+pkgname='python-pywatchman'
+pkgver=1.4.1
+pkgrel=0
+pkgdesc="Watchman client for python"
+url="https://github.com/facebook/watchman"
+depends=('python')
+optdepends=('watchman')
+license=('Apache')
+arch=('x86_64')
+makedepends=('python' 'python-setuptools')
+source=("https://pypi.python.org/packages/source/p/pywatchman/pywatchman-$pkgver.tar.gz")
+
+package() {
+ cd "$srcdir/pywatchman-$pkgver"
+ python setup.py build
+ python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
+}
+
+md5sums=('d770d09bd105e83013f63492fce70c6f')