summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d87b71f0d39f..d6c8d5e2aa27 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
-# Maintainer: Shae VanCleave
+# Maintainer: keutain < quentin dot aniere at gmail dot com>
+# Contributor: Shae VanCleave
pkgname=python-pywebview
-pkgver=4.4.1
+pkgver=5.1
pkgrel=1
pkgdesc="Build GUI for your Python program with JavaScript, HTML, and CSS."
arch=('any')
@@ -20,7 +21,7 @@ optdepends=('pyside2: use with QtPy, PySide2'
install="$pkgname.install"
source=("https://pypi.python.org/packages/source/p/pywebview/pywebview-$pkgver.tar.gz"
"https://raw.githubusercontent.com/r0x0r/pywebview/$pkgver/LICENSE")
-sha256sums=('ea4c517e9265fadfd77937facb67787c07425d303b00b9d5c3a401bbb4576941'
+sha256sums=('87eb60c299de5f20269aa18588ca6dd0d79580df5adc6edf8ac1e184fbe4885c'
'4a988dd3598832cd3653de20dc33cb677d0fb53ab5551c879ca31280ae653675')
build() {
@@ -31,6 +32,7 @@ build() {
package() {
cd "${srcdir}"
install -Dm 644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
cd "pywebview-${pkgver}"
python -m installer --destdir="$pkgdir" dist/*.whl
}