summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 14 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fc6b7b8ea0ba..92dc066a1f91 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,29 @@
# Maintainer: Sean Enck <enckse@gmail.com>
_name=pyxstitch
pkgname=python-$_name
-pkgver=1.7.4
-pkgrel=2
+pkgver=1.7.5
+pkgrel=1
pkgdesc="takes source code files and produces syntax-highlighted patterns for cross stitching."
arch=("any")
url="https://github.com/enckse/$_name"
license=('MIT')
depends=('python' 'python-pillow' 'python-pygments')
optdepends=("bash-completion: for bash completions")
-_md5='b2fe3d58780f42796fb3dfa7c99d1371'
+_md5='ddbd4b9af33c8928d485a40991503e10'
_rawcontent="https://raw.githubusercontent.com/enckse/$_name/v$pkgver/"
-source=("https://pypi.python.org/packages/fa/5a/03d6f4e539e0c562472bbf9303c568ac7cdc1f6189640c598051ee4a0abb/$_name-$pkgver.tar.gz#md5=$_md5"
+source=("https://pypi.python.org/packages/76/6d/3a3aef1df4d4493e7ca0caac1baa7b8f88d3c2d16e47a8dbc27c098c6f0b/$_name-$pkgver.tar.gz#md5=$_md5"
"${_rawcontent}LICENSE"
- "${_rawcontent}completions/bash")
-md5sums=("$_md5" "09b2ac6fbde8b1a1c4f223aa3ffedbba" "d4f45e5816e653b3ba21c779bbe9e5da")
+ "${_rawcontent}completions/bash"
+ "https://raw.githubusercontent.com/enckse/$_name/v$pkgver/doc/$_name.1")
+md5sums=("$_md5" "09b2ac6fbde8b1a1c4f223aa3ffedbba" "d4f45e5816e653b3ba21c779bbe9e5da" "3c50ed3d3821118146eb70ac526f5593")
+
+build() {
+ sed -i "s/<Date>/$(date +"%B %Y")/g;s/<Version>/$pkgver/g" pyxstitch.1
+ gzip pyxstitch.1
+}
+
package() {
+ install -Dm644 pyxstitch.1.gz $pkgdir/usr/share/man/man1/pyxstitch.1.gz
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
install -Dm 644 bash $pkgdir/usr/share/bash-completion/completions/pyxstitch
cd "$srcdir/$_name-$pkgver"