summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e87fe0b0ee3f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Sean Enck <enckse@gmail.com>
+
+_name=pyxstitch
+pkgname=python-$_name
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="takes source code files and produces syntax-highlighted patterns for cross stitching."
+arch=("any")
+url="https://github.com/enckse/$_name"
+license=('MIT')
+depends=('python' 'python-webcolors' 'python-pillow' 'python-pygments')
+source=("https://github.com/enckse/$_name/archive/v$pkgver.tar.gz")
+md5sums=('db4847a30628d7ae51e53cb5583339e8')
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+