summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5917aadcf9a6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Juliette Monsel <j_4321 at protonmail dot com>
+pkgname=('python-pyzotero')
+pkgver=1.4.6
+pkgrel=1
+_name=pyzotero
+pkgdesc="Python client for the Zotero API"
+arch=('any')
+url="https://github.com/urschrei/pyzotero"
+license=('MIT')
+source=("$_name-$pkgver.tar.gz::https://github.com/urschrei/pyzotero/archive/v$pkgver.tar.gz")
+sha512sums=('e17353d4f4a4cb95346bb3850835aa1b4815bb08b400a0f9c2e97ece786cb65169120797361325b835d2322614662952a6f3c0213c278f499283e7d2f40984d7')
+makedepends=('python-setuptools')
+depends=('python-feedparser' 'python-pytz' 'python-pathlib' 'python-pathlib' 'python-bibtexparser')
+
+build() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ install -D -m644 "license.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ python setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
+}