summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 13 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 26178c52e3f1..6c0c1aeff745 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,19 @@
# Maintainer: gmes78 <gmes.078 at gmail dot com>
pkgname=python-qasync-git
-pkgver=v0.9.1.r5.g1d83438
+pkgver=v0.26.1.r0.gee9b0a3
pkgrel=1
-pkgdesc="Python library for using asyncio in Qt-based applications"
+pkgdesc="Python library for using asyncio in Qt-based applications (Git version)"
arch=(any)
url="https://github.com/CabbageDevelopment/qasync"
license=("BSD")
depends=("python")
-makedepends=("git" "python-setuptools")
+makedepends=("git" "python-build" "python-installer")
optdepends=("python-pyqt5: PyQt5 support"
- "pyside2: PySide2 support")
+ "python-pyqt6: PyQt6 support"
+ "pyside2: PySide2 support"
+ "pyside6: PySide6 support")
provides=("python-qasync")
conflicts=("python-qasync")
@@ -23,8 +25,13 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+build() {
+ cd qasync
+ python -m build --wheel --no-isolation
+}
+
package() {
cd qasync
- python setup.py install --root="$pkgdir/" --optimize=1
- install -m644 -D LICENSE "$pkgdir/usr/share/licenses/$pkgname"
+ python -m installer --destdir="$pkgdir/" dist/*.whl
+ install -m644 -D LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}