summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 2 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3a38354a2db4..3b5e73f42bf3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: nullableVoidPtr <nullableVoidPtr _ gmail _ com>
pkgname=python-qiling-git
-pkgver=1.2.2.r62.ge4f07cf1
+pkgver=1.4.0.r7.gf050f42a
pkgrel=1
pkgdesc="An advanced binary emulation framework"
url='https://qiling.io/'
@@ -9,7 +9,7 @@ arch=('x86_64')
license=('GPL2')
depends=('python' 'python-capstone' 'python-unicorn' 'python-pefile'
'python-registry' 'python-keystone' 'python-pyelftools'
- 'python-gevent')
+ 'python-gevent' 'python-multiprocess')
makedepends=('git' 'python-setuptools')
provides=(${pkgname%-*}=$pkgver)
conflicts=(${pkgname%-*})
@@ -31,14 +31,3 @@ package() {
export PYTHONHASHSEED=0
python setup.py install --root="${pkgdir}" -O1 --skip-build
}
-
-check() {
- cd "${srcdir}/${pkgname}/tests"
- python3 ./test_posix.py &&
- python3 test_elf_multithread.py &&
- python3 test_android.py &&
- python3 ./test_debugger.py &&
- python3 ./test_uefi.py &&
- python3 ./test_shellcode.py &&
- python3 ./test_edl.py
-}