summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD78
1 files changed, 40 insertions, 38 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b886aa96e1e3..a398cd8e3fdf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,24 @@
# Maintainer: Iyán Méndez Veiga <me (at) iyanmv (dot) com>
_pkgname=qiskit
pkgname=python-${_pkgname}
-pkgver=1.0.1
+pkgver=1.1.0
pkgrel=1
epoch=1
pkgdesc="An open-source SDK for working with quantum computers at the level of extended quantum circuits, operators, and primitives"
-arch=('x86_64')
-url="https://github.com/Qiskit/qiskit"
-license=('Apache-2.0')
-provides=('python-qiskit-terra')
-conflicts=('python-qiskit-terra')
+arch=(x86_64)
+url=https://github.com/Qiskit/qiskit
+license=(Apache-2.0)
+conflicts=(python-qiskit-terra)
depends=(
- 'cython'
- 'python-dateutil'
- 'python-dill'
- 'python-numpy'
- 'python-rustworkx'
- 'python-scipy'
- 'python-stevedore'
- 'python-symengine'
- 'python-sympy'
+ cython
+ python-dateutil
+ python-dill
+ python-numpy
+ python-rustworkx
+ python-scipy
+ python-stevedore
+ python-symengine
+ python-sympy
)
optdepends=(
'ipython: interactivity'
@@ -28,7 +27,7 @@ optdepends=(
'python-matplotlib: plotting support'
'python-pillow: image support'
"python-pydot: Graphviz's Dot support"
- "python-pylatexenc: LaTeX support'emoji selector"
+ 'python-pylatexenc: LaTeX support emoji selector'
'python-qiskit-aer: high performance simulator for quantum circuits'
'python-qiskit-experiments: tools for building, running, and analysis of experiments on noisy quantum computers'
'python-qiskit-finance: stock/securities problems, portfolio optimizations and finance experiments'
@@ -41,39 +40,42 @@ optdepends=(
'python-z3-solver: theorem prover'
)
makedepends=(
- 'python-build'
- 'python-installer'
- 'python-setuptools'
- 'python-setuptools-rust'
- 'python-wheel'
+ python-build
+ python-installer
+ python-setuptools
+ python-setuptools-rust
+ python-wheel
)
#checkdepends=(
-# 'python-anyio'
-# 'python-ddt'
-# 'python-hypothesis'
-# 'python-pytest'
-# 'python-pytest-benchmark'
-# 'python-pytest-xdist'
+# ipython
+# python-anyio
+# python-ddt
+# python-hypothesis
+# python-pytest
+# python-pytest-benchmark
+# python-pytest-mock
+# python-pytest-xdist
#)
-source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/Qiskit/${_pkgname}/archive/${pkgver}.tar.gz")
-b2sums=('fcc9eb8ea4b3ceeea3238b927d68cd7cc20ea4ed74e981122d922a2bdfca13d55628c7947129cfd4fe9aa2cdf4fc5e07ff9252ffac95527daf2231436ba2b8a7')
+source=($_pkgname-$pkgver.tar.gz::https://github.com/Qiskit/$_pkgname/archive/$pkgver.tar.gz)
+b2sums=('b188fe116ff5d0fa498e2b5c829b61950043163528ff39a51701d4f497a9dc0e1ffa27c518833dec84198682477c3398e8edb737d74b4f321b70fb3971b25a57')
+
build() {
- cd "${_pkgname}-${pkgver}"
+ cd $_pkgname-$pkgver
python -m build --wheel --no-isolation
}
#check() {
-# local python_version=$(python -c 'import sys; print("".join(map(str, sys.version_info[:2])))')
-# cd "${_pkgname}-${pkgver}"
-# python -m installer --destdir=test_dir dist/*.whl
-# # Delete qiskit folder so that the installed package is loaded and not the src
-# rm -rf qiskit
-# PYTHONPATH="$PWD/build/lib.linux-$CARCH-cpython-${python_version}" pytest -v -k 'not test_examples' test/python
+# cd $_pkgname-$pkgver
+# local _site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
+# python -m installer --destdir=../test_dir dist/*.whl
+# # Delete qiskit folder in src to be sure we test with installed package
+# rm -r qiskit
+# PYTHONPATH=../test_dir/$_site_packages pytest -v test/python
#}
package() {
- cd "${_pkgname}-${pkgver}"
+ cd $_pkgname-$pkgver
python -m installer --destdir="$pkgdir" dist/*.whl
- install -D -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m644 LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}