summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e6a0e207384c..cabc49ff1a9b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: DanManN <dnahimov@gmail.com>
pkgname=python-qiskit-sdk-git
-pkgver=0.4.8.r484.g23d7ea5
-pkgrel=4
+pkgver=0.7.0
+pkgrel=5
pkgdesc="Python software development kit for writing quantum computing experiments, programs, and applications."
arch=('any')
url="http://www.qiskit.org"
license=('Apache-2.0')
groups=('QISKit')
-depends=('python' 'python-jsonschema' 'python-networkx' 'python-ply' 'python-numpy' 'python-scipy' 'python-matplotlib' 'python-pillow' 'python-sympy' 'python-qiskit-api')
+depends=('python' 'python-psutil' 'python-jsonschema' 'python-networkx' 'python-ply' 'python-numpy' 'python-scipy' 'python-matplotlib' 'python-pillow' 'python-sympy' 'python-qiskit-api')
makedepends=('git' 'cmake' 'python-setuptools' 'python-pylint' 'python-pycodestyle' 'python-sphinx' 'python-sphinxcontrib-fulltoc' 'python-coverage' 'python-better-apidoc' 'python-wheel')
provides=('python-qiskit-sdk')
conflicts=('python-qiskit-sdk')
@@ -16,7 +16,7 @@ md5sums=('SKIP')
pkgver() {
cd qiskit-terra
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cat qiskit/VERSION.txt || git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {