summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a0795080496a..907574748600 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,23 @@
pkgname='python-quantiphy'
_pkgname=${pkgname#python-}
-pkgver=2.17.0
+pkgver=2.18.0
pkgrel=1
pkgdesc="Offers support for the pairing of a number and a unit of measure"
arch=('any')
depends=()
-makedepends=('python-setuptools')
+makedepends=(python-build python-installer python-wheel python-flit-core)
url="https://github.com/KenKundert/$_pkgname"
license=('GPL3')
-source=("https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
-sha256sums=('9660efae946ab5374c809cb8a771f6092602cc32f0d36c2726de153a0817ff42')
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
+sha256sums=('eca14abfa83c3171cea7212a1a11fd6e004d029e5500b342b260b48c72f50d66')
build() {
- cd $_pkgname-$pkgver
- python setup.py build
+ cd "$_pkgname-$pkgver"
+ python -m build --wheel --no-isolation
}
package() {
- cd $_pkgname-$pkgver
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ cd "$_pkgname-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}