summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 285024c45959..abfda41b2057 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=('python-rebulk' 'python2-rebulk')
_name=${pkgname#python-}
pkgver=3.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="Define simple search patterns in bulk to perform advanced matching on any string. "
arch=("any")
url="https://github.com/Toilal/rebulk"
@@ -12,8 +12,12 @@ license=('MIT')
makedepends=('python-setuptools'
'python2-setuptools')
options=(!emptydirs)
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha512sums=('f1b2dffad68d7cc3e8a6949c3605a6c0fe503cf59434cdff99952dc836839ecb3d411d244cf0e54069672fec9a6c4826efff3b7777f7e0557c667f947ec2bd74')
+
+# The pypi source is different from github.
+#source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+source=("rebulk-${pkgver}.tar.gz::https://github.com/Toilal/rebulk/archive/v${pkgver}.tar.gz")
+
+sha512sums=('eb474b8b8509f291938bc3c96ef591b8233a41b9eb28f7957f3d20e098140ac6d80a1337c6ff1c89eeea4c34f94eb37af811d2200a8f2a574fc93b8fa1ea3c5d')
prepare() {
cp -a "rebulk-${pkgver}"{,-py2}
@@ -22,10 +26,6 @@ prepare() {
check() {
cd "${srcdir}/rebulk-${pkgver}"
python setup.py test
-
- # Tests don't work in python2, issue Toilal/rebulk/issues/19
- #cd "${srcdir}/rebulk-${pkgver}-py2"
- #python2 setup.py test
}
package_python-rebulk() {