summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 95b13d7c2cef..b79626eee581 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=python-remote_ikernel
_name=${pkgname#python-}
pkgver=0.4.6
-pkgrel=1
+pkgrel=2
pkgdesc="Remote kernel setup for Jupyter"
arch=(any)
url="https://bitbucket.org/tdaff/remote_ikernel"
@@ -11,13 +11,15 @@ license=('BSD')
depends=('python-pexpect' 'jupyter-notebook')
makedepends=('python-setuptools')
source=(https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz
-'host.patch')
+'host.patch' 'usrfix.patch')
sha256sums=('740b80a57fa1af40cadef541c5a4eb293675b504092ecf00c57dd2f0011bd840'
- 'bf209f55f6dea633e09a7f809ae9e1aa7c0d9fdfd0d026d8cf900b7a6d8cf6af')
+ 'bf209f55f6dea633e09a7f809ae9e1aa7c0d9fdfd0d026d8cf900b7a6d8cf6af'
+ 'f8c57fc530c8ba51f8baa27bb3c4e9e1ad9bc84cf841a5ebf04ffed58e58ceb2')
prepare() {
cd "$srcdir/$_name-$pkgver"
patch -Np1 < ../host.patch
+ patch -Np1 < ../usrfix.patch
}
build() {
@@ -28,4 +30,5 @@ build() {
package() {
cd "$srcdir/$_name-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm 644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}