summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b3f183fde71d..919830813088 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgbase=python-reproject
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}" "python-${_pyname}-doc")
-pkgver=0.7
+pkgver=0.7.1
pkgrel=1
pkgdesc="Python-based Astronomical image reprojection"
arch=('i686' 'x86_64')
@@ -11,7 +11,7 @@ license=('BSD')
makedepends=('cython' 'python-setuptools-scm' 'python-extension-helpers' 'python-sphinx-astropy' 'python-astropy-healpix' 'python-pyvo' 'python-mimeparse')
checkdepends=('python-shapely' 'python-pytest-astropy')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('ff2821e83ac2d68a8fecdee1ebcc2d45')
+md5sums=('817570e405d3b4b173fc3e098f83a54a')
_pyver=$(python -V | cut -c 8-10)
prepare() {
@@ -30,11 +30,11 @@ build() {
check() {
cd ${srcdir}/${_pyname}-${pkgver}/build/lib.linux-${CARCH}-${_pyver}
- PYTHONPATH="build/lib.linux-${CARCH}-${_pyver}" pytest
+ pytest
}
package_python-reproject() {
- depends=('python>=3.6' 'python-numpy>=1.13' 'python-scipy>=0.9' 'python-astropy>=3.2' 'python-astropy-healpix>=0.2')
+ depends=('python>=3.6' 'python-numpy>=1.13' 'python-scipy>=1.1' 'python-astropy>=3.2' 'python-astropy-healpix>=0.2')
optdepends=('python-shapely>=1.6: For some of the mosaicking functionality'
'python-reproject-doc: Documentation for Reproject'
'python-pytest-astropy: For testing')