summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD65
1 files changed, 42 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2a7f67bf52c5..1530ff8c7fb0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,49 @@
-# Maintainer: Aniket Pradhan <aniket17133[at]iiitd[dot]ac[dot]in>
-# Contributer: Roman Haritonov <reclosedev[at]gmail[dot]com>
-
-_pkgname="requests-cache"
-pkgname="python-requests-cache"
-pkgver=0.5.0
+# Maintainer: Jordan Cook <JCook83@gmail.com>
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Maintainer: Philipp A. <flying-sheep@web.de>
+# Contributor: Benoit Pierre <benoit.pierre@gmail.com>
+# Contributor: Simon Legner <Simon.Legner@gmail.com>
+# Contributor: Aniket Pradhan <aniket17133[at]iiitd[dot]ac[dot]in>
+# Contributor: Roman Haritonov <reclosedev[at]gmail[dot]com>
+_base=requests-cache
+pkgname=python-${_base}
+pkgdesc="A persistent cache for python requests"
+pkgver=1.2.0
pkgrel=1
-pkgdesc="Transparent persistent cache for http://python-requests.org/ library."
-arch=("x86_64")
-url="https://github.com/reclosedev/requests-cache"
-license=("BSD")
-depends=("python" "python-requests")
-makedepends=("git" "python-setuptools")
-provides=("python-requests-cache")
-conflicts=("python2-requests-cache")
-source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/reclosedev/requests-cache/archive/v${pkgver}.tar.gz")
-sha256sums=('7846f008cd09ee1d38b5285bf098f9f0246cd1019d8c519d23184c1616342217')
+arch=(any)
+url="https://github.com/${_base}/${_base}"
+license=('custom:BSD-2-clause')
+depends=(python-requests python-cattrs python-platformdirs python-url-normalize)
+makedepends=(python-build python-installer python-poetry-core python-wheel)
+optdepends=('python-boto3: Cache backend for Amazon DynamoDB database'
+ 'python-botocore: Interface for Amazon Web Services'
+ 'python-pymongo: Cache backend for MongoDB database'
+ 'python-redis: Cache backend for Redis cache'
+ 'python-bson: for BSON codec'
+ 'python-itsdangerous: for pass trusted data to untrusted environments'
+ 'python-yaml: for bindings yaml support'
+ 'python-ujson: for JSON serializer for improved performance'
+)
+checkdepends=(python-pytest python-requests-mock python-responses python-timeout-decorator
+ python-time-machine python-rich python-ujson python-itsdangerous)
+source=(${_base}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
+sha512sums=('b198d282cfd656c432d3a63f4d615191ac1ff97c9563e9bd6945e7a78444601108beb47a0f4a79740c7bd6942c3753f025cd52457e87ece7964229799bbb8fa1')
build() {
- cd "$srcdir/$_pkgname-${pkgver}"
- python setup.py build
+ cd ${_base}-${pkgver}
+ # Note: set `GIT_CEILING_DIRECTORIES` to prevent poetry
+ # from incorrectly using a parent git checkout info.
+ # https://github.com/pypa/build/issues/384#issuecomment-947675975
+ GIT_CEILING_DIRECTORIES="${PWD}/.." python -m build --wheel --skip-dependency-check --no-isolation
}
-package() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+check() {
+ cd ${_base}-${pkgver}
+ python -m pytest --ignore=tests/integration
+}
- install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dm 644 README.rst "${pkgdir}/usr/share/doc/${pkgname}/README"
+package() {
+ cd ${_base}-${pkgver}
+ python -m installer --destdir="${pkgdir}" dist/*.whl
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}