summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2117443377ca..dda651bbb01f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
pkgname=python-requests-gpgauthlib
pkgver=0.1.2
-pkgrel=1
+pkgrel=2
pkgdesc='A GPGAuth Client in Python'
arch=('any')
url='https://github.com/liip/requests_gpgauthlib'
license=('GPL3')
-depends=('python')
-makedepends=('python-setuptools')
-source=("https://github.com/liip/requests_gpgauthlib/archive/${pkgver}.tar.gz")
+depends=('python' 'python-gnupg' 'python-requests')
+makedepends=('python-setuptools' 'python-pytest' 'python-tests' 'python-mock' 'python-requests-mock')
+source=("https://github.com/liip/requests_gpgauthlib/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz")
b2sums=('ee17a073377f7b413bb9377b04ba99188794cf67433c60d087f667bd89e479e470f6a1f3e4d564cd90981300a3734f68d14cb66e25e20828ff27c7f17386cbf6')
build() {
@@ -17,6 +17,12 @@ build() {
python setup.py build
}
+# fails atm
+# check() {
+# cd requests_gpgauthlib-${pkgver}
+# python -m pytest
+# }
+
package() {
cd requests_gpgauthlib-${pkgver}
NO_THIRD_PARTY=true python setup.py install --skip-build --root="${pkgdir}" --optimize=1