summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5d12d7fad843..91a526b0c597 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,27 @@
-# Maintainer: Eric Hugoson
+# Maintainer: Matthew Sexton <matthew@asylumtech.com>
+# Contributor: Eric Hugoson
_pkgname=requirements-detector
pkgname=python-requirements-detector
-pkgver=0.6
+pkgver=1.2.2
pkgrel=1
-pkgdesc="A library that can be used to retrieve program settings from a variety of sources"
+pkgdesc="A simple Python tool which attempts to find and list the requirements of a Python project"
arch=('any')
url="https://github.com/landscapeio/requirements-detector"
license=('MIT')
depends=('python-astroid')
-makedepends=('python-setuptools')
+makedepends=('python-build' 'python-installer' 'python-wheel' 'python-poetry')
source=(https://github.com/landscapeio/requirements-detector/archive/${pkgver}.tar.gz)
-sha512sums=('78723dc187a35267799780c7ddf645c7179ae8947281d2aa69f350c2bd06a29dddb13f595ee89cbbaa52f9865617084eaac645f897631cd24983967a5b392cd6')
+sha512sums=('dcef6b49a50bd48af9eb6c69d4cda00c5b11a748b03d58833aef7f0646e6fe7223315c9a0cd9d87058376dc21563b0d48dc3ef66a3095d113f74434371af540b')
build() {
cd "${_pkgname}-${pkgver}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "${_pkgname}-${pkgver}"
- python setup.py install --prefix="/usr" --root="${pkgdir}" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm755 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}"/LICENSE
}