summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8ef6e5643b2c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
+
+pkgname=python-rgt
+_pkgname=reg-gen
+pkgver=0.12.1
+pkgrel=1
+pkgdesc="Regulatory Genomics Toolbox"
+arch=('any')
+url=http://www.regulatory-genomics.org
+license=('custom')
+depends=('python' 'python-numpy' 'python-scipy')
+makedepends=('python-setuptools')
+source=("https://github.com/CostaLab/${_pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=('baccb00d00dd98a26954414f13fd6f8f7d4ac1f6b40d65177867237029477fcf')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py build
+}
+
+
+package(){
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:ts=2:sw=2:et: