summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6cba734c0610..589756704e28 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,23 @@
# Maintainer: Élie Bouttier <elie+aur@bouttier.eu>
-pkgname=python2-rq-dashboard
-pkgver=0.3.8
+pkgname=python-rq-dashboard
+pkgver=0.3.10
pkgrel=1
pkgdesc="Flask-based web front-end for monitoring RQ queues"
arch=('any')
license=('BSD')
-url="https://github.com/ducu/rq-dashboard/"
-makedepends=('python2' 'python2-setuptools')
-depends=('python2' 'python2-click' 'python2-flask' 'python2-redis'
- 'python2-rq' 'python2-arrow')
+url="https://github.com/eoranged/rq-dashboard/"
+makedepends=('python' 'python-setuptools')
+depends=('python' 'python-click' 'python-flask' 'python-redis'
+ 'python-rq' 'python-arrow')
source=("${url}archive/${pkgver}.tar.gz")
-sha256sums=('a32b81009f0a4986f67272df74b9d808df2faa028f223eff3f5a3850c6006a2d')
+sha256sums=('ba0103b2fcfd1b09530e0fc1a11b66280ce2ea71f123357db0725687668dbe60')
package() {
cd "${srcdir}/rq-dashboard-${pkgver}"
- python2 setup.py install --root="${pkgdir}" -O1
+ python setup.py install --root="${pkgdir}" -O1
+ mv "${pkgdir}/usr/bin/rq-dashboard"{,3}
+ ln -s "/usr/bin/rq-dashboard3" "${pkgdir}/usr/bin/rq-dashboard"
install -Dm644 "LICENSE" "${srcdir}/usr/share/licenses/${pkgname}/LICENSE"
}