summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e8a13b4e2086..8d6a31fde3ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,16 +3,18 @@
_pkgname=rst2pdf
pkgname=python-rst2pdf
pkgver=0.93
-pkgrel=1
+pkgrel=2
pkgdesc='Convert restructured text to PDF via reportlab.'
arch=('any')
-url='https://github.com/ralsina/$_pkgname'
+url="https://github.com/$_pkgname/$_pkgname"
license=('MIT')
+conflicts=(python2-rst2pdf)
depends=('python-setuptools' 'python-docutils' 'python-reportlab>=2.4' 'python-pygments' 'python-pdfrw')
source=("$url/archive/$pkgver.tar.gz")
md5sums=('91ee1eb4d22162366262c0aa00447525')
package() {
cd "$srcdir/$_pkgname-$pkgver"
+ 2to3 -w .
python setup.py install --root="$pkgdir/" --optimize=1
} \ No newline at end of file