summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 25 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 898bcd9c7acf..6295d2e9d7b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,34 @@
-# Maintainer: Nils Steinger (voidptr.de)
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Nils Steinger (voidptr.de)
+
pkgname=python-rubymarshal
-_pkgname=rubymarshal
-pkgver=1.0.3
+pkgver=1.2.10
pkgrel=1
-pkgdesc='Read and write serialized data from the Ruby Marshal library'
+pkgdesc="Read and write Ruby-Marshalled data"
url='https://github.com/d9pouces/RubyMarshal'
arch=('any')
license=('custom:WTFPL')
depends=('python')
-source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
-md5sums=('df3c6b114637993adc5d3941c941f0d3')
+makedepends=('python-setuptools' 'python-sphinx')
+checkdepends=('python-nose>=1.3.7' 'python-hypothesis>=5.24.0' 'python-pytest')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha256sums=('a09bccd8125e8e09f9c11146fafaba5283d16c369d0751f9765ddc009321df9e')
-package() {
- cd "$srcdir/$_pkgname-$pkgver"
- python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
- install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+build() {
+ cd "RubyMarshal-$pkgver"
+ python setup.py build
+ cd doc
+ make man
+}
+
+check() {
+ cd "RubyMarshal-$pkgver"
+ nosetests rubymarshal_tests
}
+package() {
+ cd "RubyMarshal-$pkgver"
+ PYTHONHASHSEED=0 python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm 644 doc/build/man/rubymarshal.1 -t "$pkgdir/usr/share/man/man1/"
+}