summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0d494d098f14
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+pkgbase=python-salib
+pkgname=('python-salib' 'python2-salib')
+pkgver=0.4
+pkgrel=1
+pkgdesc="Sensitivity Analysis Library in Python (Numpy). Contains Sobol, Morris, and FAST methods."
+url="https://github.com/jdherman/SALib"
+arch=(any)
+license=('LGPL')
+makedepends=('python-setuptools' 'python2-setuptools')
+source=("https://github.com/jdherman/SALib/archive/v$pkgver.tar.gz")
+md5sums=('6f93928c45a43c2cffa0512fda407100')
+
+build() {
+ cp -r "${srcdir}"/SALib-$pkgver "${srcdir}"/SALib-$pkgver-py2
+
+ cd "${srcdir}"/SALib-$pkgver
+ python setup.py build
+
+ cd "${srcdir}"/SALib-$pkgver-py2
+ python2 setup.py build
+}
+
+package_python-salib() {
+ depends=('python-scikit-learn')
+
+ cd "${srcdir}/SALib-$pkgver"
+ python setup.py install --root=${pkgdir}
+}
+
+package_python2-salib() {
+ depends=('python2-scikit-learn')
+
+ cd "${srcdir}/SALib-$pkgver"
+ python2 setup.py install --root=${pkgdir}
+}