summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 10 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 18b8058baccf..00ade7e3e94c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer: Carl George < arch at cgtx dot us >
_name="sanic"
-pkgname="python-${_name}"
-pkgver="0.2.0"
-pkgrel="1"
+pkgname="python-$_name"
+pkgver=0.3.0
+pkgrel=1
pkgdesc="A microframework based on uvloop, httptools, and learnings of flask"
arch=("any")
url="https://github.com/channelcat/sanic"
license=("MIT")
makedepends=("python-setuptools")
-source=("https://github.com/channelcat/sanic/archive/${pkgver}.tar.gz")
-sha256sums=('eda329ee2d4894e1564e40152203532291bec7ac764005946619825aaeee2985')
+source=("https://github.com/channelcat/sanic/archive/$pkgver.tar.gz")
+sha256sums=('bee1f2df2494af386085d8d4767de5d8c817b706d987faa57c29a527995e393f')
build() {
- cd "${srcdir}/${_name}-${pkgver}"
+ cd "$_name-$pkgver"
python setup.py build
}
@@ -21,9 +21,8 @@ package() {
depends=("python-uvloop>=0.5.3"
"python-httptools>=0.0.9"
"python-ujson>=1.35"
- "python-aiofiles>=0.3.0"
- "python-multidict>=2.0")
- cd "${srcdir}/${_name}-${pkgver}"
- python setup.py install --skip-build --root="${pkgdir}" --optimize=1
- install -Dm0644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ "python-aiofiles>=0.3.0")
+ cd "$_name-$pkgver"
+ python setup.py install --skip-build --root="$pkgdir" --optimize=1
+ install -D --mode 644 --target-directory "$pkgdir/usr/share/licenses/$pkgname" LICENSE
}