summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7d9635314a0a..41ad6612a273 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,16 +6,19 @@ pkgbase=python-scikit-image
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}")
pkgver=0.15.0
-pkgrel=1
+pkgrel=2
pkgdesc="Image processing routines for SciPy"
arch=('i686' 'x86_64')
url="http://scikit-image.org/"
license=('BSD')
-makedepends=('cython' 'python-six')
-depends=('python-scipy' 'python-matplotlib' 'python-networkx' 'python-pillow' 'python-pywavelets')
-optdepends=('python-pyqt4: for imshow(x, fancy=True) and skivi'
+makedepends=('cython>=0.23.4')
+depends=('python-numpy>=1.11' 'python-scipy>=0.17.0' 'python-matplotlib>3.0.0' 'python-networkx>=2.0' 'python-pillow>=4.3.0' 'python-pywavelets>=0.4.0' 'python-imageio>=2.0.1')
+optdepends=('python-pyqt5: for imshow(x, fancy=True) and skivi'
+ 'python-qtpy'
'freeimage: for reading various types of image file formats'
- 'python-pyamg: fast cg_mg mode of random walker segmentation')
+ 'python-pyamg: fast cg_mg mode of random walker segmentation'
+ 'python-imread: Optional I/O plugin providing most standard formats'
+ 'python-simpleitk: Optional I/O plugin providing a wide variety of formats. including specialized formats using in medical imaging')
options=('!emptydirs')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
sha256sums=('df111e654b47e5ea456c50553debe4c5ddd97258894c7ad3b7f2f9f10798e053')