summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 28 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7257bcf3370e..e84c9231ba99 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,44 @@
# Maintainer: sasvari <sasvari@fastmail.com>
# adapted from package python2-scikit-rf
pkgname="python-scikit-rf"
-pkgver=0.23.1
+pkgver=0.32.0
pkgrel=1
pkgdesc="Scikit-rf (aka skrf) is a python package for RF/Microwave engineering"
arch=(any)
-url="http://scikit-rf-web.readthedocs.org"
+url="https://github.com/scikit-rf/scikit-rf"
license=("BSD")
-depends=("python" "python-numpy" "python-scipy"
- "python-matplotlib" "python-pandas" "python-xlwt"
- "python-openpyxl" "python-networkx")
+depends=(
+ "python"
+ "python-matplotlib"
+ "python-nbsphinx"
+ "python-networkx"
+ "python-numpy"
+ "python-openpyxl"
+ "python-pandas"
+ "python-scipy"
+ "python-xlwt"
+)
+makedepends=(python-build python-installer python-wheel)
optdepends=(
"python-pyvisa: for instrument control"
"python-vxi11: for instrument control over ethernet"
"python-xlrd: for xls reading"
+ "python-pyqt5: qtapps"
+ "python-pyqt: qtapps"
+ "python-pyqgraph: qtapps"
)
-sha256sums=('7c8c15a81807f60645154aa7ac1e83572b14f22b60dd06d093babaa5fbf52e00')
-source=("${pkgname}-${pkgver}::https://github.com/scikit-rf/scikit-rf/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('b0e2ceef1b8178a0344c7967185b6a81a2ae2d0bd656ea578b0aa1fbab07b256')
+source=("${pkgname}-${pkgver}::https://github.com/scikit-rf/scikit-rf/archive/refs/tags/v.${pkgver}.tar.gz")
+
+
+build() {
+ cd "${srcdir}/scikit-rf-v.${pkgver}"
+ export PYTHONHASHSEED=0
+ python -m build --wheel --no-isolation
+}
package() {
- cd "$srcdir/scikit-rf-$pkgver"
- python setup.py install --optimize=1 --root="$pkgdir/" --prefix="/usr"
+ cd "${srcdir}/scikit-rf-v.${pkgver}"
+ find dist -name '*.whl' -exec python -m installer --compile-bytecode 1 --destdir="${pkgdir}" {} \;
}