summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 8 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 87f9f40bd6dc..e0f67c8d88e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,8 +8,14 @@ pkgdesc="Python scikit for building and analyzing recommender systems"
arch=('any')
license=('BSD-3-Clause')
url="https://github.com/NicolasHug/${_reponame}"
-depends=()
-makedepends=('python-setuptools' 'cython' 'python-numpy')
+depends=('python-joblib' 'python-numpy' 'python-scipy' 'python-six')
+optdepends=("flake8: code linting to comply with contributing standards"
+ "python-pandas: dataframe handling"
+ "python-pytest: test suite"
+ "python-sphinx: documentation generator"
+ "python-sphinx_rtd_theme: Read The Docs theme for documentation generator"
+ "python-sphinxcontrib-spelling: spelling extension for documentation generator")
+makedepends=('python-setuptools' 'cython')
provides=()
conflicts=()
source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/NicolasHug/${_reponame}/archive/v${pkgver}.tar.gz")
@@ -23,14 +29,6 @@ build() {
}
package() {
- depends=('python-joblib' 'python-numpy' 'python-scipy' 'python-six')
- optdepends=("flake8: code linting to comply with contributing standards"
- "python-pandas: dataframe handling"
- "python-pytest: test suite"
- "python-sphinx: documentation generator"
- "python-sphinx_rtd_theme: Read The Docs theme for documentation generator"
- "python-sphinxcontrib-spelling: spelling extension for documentation generator")
-
cd "${srcdir}/${_reponame}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
ln -s surprise "${pkgdir}/usr/bin/surprise3"