summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 10 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c1f01234a2ca..4de5f626e4f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,10 +8,16 @@ pkgdesc="Python scikit for building and analyzing recommender systems"
arch=('any')
license=('BSD-3-Clause')
url="https://github.com/NicolasHug/${_reponame}"
-depends=()
-makedepends=('git' 'python-setuptools' 'cython' 'python-numpy')
-provides=()
-conflicts=()
+depends=('python-joblib' 'python-numpy' 'python-scipy' 'python-six')
+optdepends=("flake8: code linting to comply with contributing standards"
+ "python-pandas: dataframe handling"
+ "python-pytest: test suite"
+ "python-sphinx: documentation generator"
+ "python-sphinx_rtd_theme: Read The Docs theme for documentation generator"
+ "python-sphinxcontrib-spelling: spelling extension for documentation generator")
+makedepends=('git' 'python-setuptools' 'cython')
+provides=("python-scikit-surprise=${pkgver}")
+conflicts=("python-scikit-surprise")
source=("git+https://github.com/NicolasHug/${_reponame}")
sha512sums=('SKIP')
@@ -31,16 +37,6 @@ build() {
}
package() {
- depends=('python-joblib' 'python-numpy' 'python-scipy' 'python-six')
- optdepends=("flake8: code linting to comply with contributing standards"
- "python-pandas: dataframe handling"
- "python-pytest: test suite"
- "python-sphinx: documentation generator"
- "python-sphinx_rtd_theme: Read The Docs theme for documentation generator"
- "python-sphinxcontrib-spelling: spelling extension for documentation generator")
- provides=("python-scikit-surprise=${pkgver}")
- conflicts=("python-scikit-surprise")
-
cd "${srcdir}/${_reponame}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
ln -s surprise "${pkgdir}/usr/bin/surprise3"