summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 17 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index befa6dc79fa1..5ab46f024d7f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,25 @@
-# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
-
-pkgname=python-scikit-umfpack
-pkgver=0.3.2
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: Grey Christoforo <first name [at] last name [dot] net>
+_base=scikit-umfpack
+pkgname=python-${_base}
+pkgver=0.4.0
pkgrel=1
-pkgdesc="Python interface to UMFPACK sparse direct solver."
-url="https://scikit-umfpack.github.io/scikit-umfpack"
-depends=('suitesparse' 'python-scipy' 'cython' 'python-numpy')
-makedepends=('swig' 'python-setuptools' 'python-pypandoc')
-license=('BSD')
+pkgdesc="Python interface to UMFPACK sparse direct solver"
+url="https://${_base}.github.io/${_base}"
+depends=(suitesparse python-scipy)
+makedepends=(python-build python-installer meson-python python-wheel swig)
+license=('custom:BSD-3-clause')
arch=('x86_64')
-source=("https://github.com/scikit-umfpack/scikit-umfpack/archive/${pkgver}.tar.gz")
-md5sums=('40f9cccda50df9b0a5efcd24521dae54')
+source=(https://pypi.org/packages/source/${_base::1}/${_base}/${_base/-/_}-${pkgver}.tar.gz)
+sha512sums=('284dc757cf7ebd1ca5aa05ca1a2778b2dee99eba7b345b74d2e2b4a7fd79058eb4f4e67f3d4582b28c57d74db2efb5dfdcfaf88154f5972082767e524fe3d6e6')
build() {
- cd "scikit-umfpack-${pkgver}"
- python setup.py build
+ cd ${_base/-/_}-${pkgver}
+ python -m build --wheel --skip-dependency-check --no-isolation
}
package() {
- cd "scikit-umfpack-${pkgver}"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ cd ${_base/-/_}-${pkgver}
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}