summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7eddf30ac0a2..c02caad5346d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgname="python-scipy-mkl"
true && pkgname=('python-scipy-mkl' 'python2-scipy-mkl')
pkgver=0.19.0
-pkgrel=1
+pkgrel=3
pkgdesc="SciPy is open-source software for mathematics, science, and engineering. Compiled with intel MKL"
arch=('i686' 'x86_64')
url="http://www.scipy.org/"
@@ -21,7 +21,7 @@ build() {
unset LDFLAGS
unset FFLAGS
export LDFLAGS=""
- export FFLAGS="-fPIC -openmp"
+ export FFLAGS="-fPIC -qopenmp -xHost"
#mv scipy-0.18.1 scipy-0.18.1
@@ -37,7 +37,9 @@ build() {
cd scipy-${pkgver}
#patch -Np1 -i $srcdir/0001-GEN-regenerate-C-sources-with-Cython-0.17.1.patch
- python setup.py build --fcompiler=intelem --compiler=intel
+ #python setup.py build --fcompiler=intelem --compiler=intel
+ python setup.py config --compiler=intelem --fcompiler=intelem build_clib --compiler=intelem --fcompiler=intelem build_ext --compiler=intelem --fcompiler=intelem
+
# build for python2
cd ../scipy-${pkgver}-py2
@@ -47,7 +49,9 @@ build() {
sed -i 's_^#!.*/usr/bin/env.*python_#!/usr/bin/env python2_' $file
done
- python2 setup.py build --fcompiler=intelem --compiler=intel
+ #python2 setup.py build --fcompiler=intelem --compiler=intel
+ python2 setup.py config --compiler=intelem --fcompiler=intelem build_clib --compiler=intelem --fcompiler=intelem build_ext --compiler=intelem --fcompiler=intelem
+
}
check() {