summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 22 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 41a65990e9db..06f28de16195 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,23 +5,25 @@ pkgname=(
'python-sdbus-networkmanager-git'
)
pkgbase='python-sdbus-git'
-pkgver=r469.14ba27e
+pkgver=r534.f59d2d7
pkgrel=1
pkgdesc="Modern Python library for D-Bus"
arch=('x86_64')
-url="https://github.com/igo95862/python-sdbus"
-license=('LGPL-2.1-or-later')
+url="https://github.com/python-sdbus/python-sdbus"
+license=('LGPL2.1')
depends=('python' 'systemd-libs')
makedepends=('git' 'python-setuptools' 'gcc')
source=(
- "$pkgbase"::"git+https://github.com/igo95862/python-sdbus"
- "python-sdbus-notifications"::"git+https://github.com/igo95862/python-sdbus-notifications"
- "python-sdbus-networkmanager"::"git+https://github.com/igo95862/python-sdbus-networkmanager"
+ "$pkgbase"::"git+https://github.com/python-sdbus/python-sdbus"
+ "python-sdbus-notifications"::"git+https://github.com/python-sdbus/python-sdbus-notifications"
+ "python-sdbus-networkmanager"::"git+https://github.com/python-sdbus/python-sdbus-networkmanager"
+ "python-sdbus-secrets"::"git+https://github.com/python-sdbus/python-sdbus-secrets"
)
md5sums=(
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
)
pkgver() {
@@ -38,6 +40,9 @@ build () {
cd "$srcdir/python-sdbus-networkmanager"
python setup.py build
+
+ cd "$srcdir/python-sdbus-secrets"
+ python setup.py build
}
check () {
@@ -62,6 +67,7 @@ package_python-sdbus-notifications-git() {
provides=('python-sdbus-notifications')
pkgdesc='Freedesktop Notifications binds for python-sdbus'
depends=('python-sdbus')
+ arch=('any')
cd "$srcdir"/python-sdbus-notifications
python setup.py install --prefix /usr --root "$pkgdir"
}
@@ -70,6 +76,16 @@ package_python-sdbus-networkmanager-git() {
provides=('python-sdbus-networkmanager')
pkgdesc='NetworkManager binds for python-sdbus'
depends=('python-sdbus')
+ arch=('any')
cd "$srcdir"/python-sdbus-networkmanager
python setup.py install --prefix /usr --root "$pkgdir"
}
+
+package_python-sdbus-secrets-git() {
+ provides=('python-sdbus-secrets')
+ pkgdesc='Freedesktop secrets binds for python-sdbus'
+ depends=('python-sdbus')
+ arch=('any')
+ cd "$srcdir"/python-sdbus-secrets
+ python setup.py install --prefix /usr --root "$pkgdir"
+}