summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 10 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f8a8ffb28f97..c1cfa55854b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,28 @@
# Maintainer: Ashley Whetter <(firstname) @ awhetter.co.uk>
-pkgname=python-seqlearn-git
+pkgbase=python-seqlearn-git
+pkgname=('python-seqlearn-git' 'python2-seqlearn-git')
pkgver=20141124
pkgrel=1
pkgdesc="A sequence classification toolkit for Python."
arch=('i686' 'x86_64')
url="http://larsmans.github.io/seqlearn/"
license=('custom: Copyright 2013-2014 Lars Buitinck / University of Amsterdam and contributors')
-groups=()
-depends=('python' 'python-numpy>=1.6' 'python-scipy>=0.11' 'cython>=0.20.2')
makedepends=('git')
-provides=()
-conflicts=()
-replaces=()
-backup=()
options=(!emptydirs)
-install=
source=(git://github.com/larsmans/seqlearn.git)
md5sums=("SKIP")
-package() {
+package_python-seqlearn-git() {
+ depends=('python' 'python-numpy>=1.6' 'python-scipy>=0.11' 'cython>=0.20.2')
cd "$srcdir/seqlearn"
python setup.py install --root="$pkgdir/" --optimize=1
}
+package_python2-seqlearn-git() {
+ depends=('python2' 'python2-numpy>=1.6' 'python2-scipy>=0.11' 'cython2>=0.20.2')
+ cd "$srcdir/seqlearn"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+
# vim:set ts=2 sw=2 et: