summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c1cfa55854b7..b82203c423b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
+# Contributor: Michal Wojdyla < micwoj9292 at gmail dot com >
# Maintainer: Ashley Whetter <(firstname) @ awhetter.co.uk>
pkgbase=python-seqlearn-git
pkgname=('python-seqlearn-git' 'python2-seqlearn-git')
-pkgver=20141124
+pkgver=r89.32d4bfa
pkgrel=1
pkgdesc="A sequence classification toolkit for Python."
arch=('i686' 'x86_64')
@@ -10,9 +11,14 @@ url="http://larsmans.github.io/seqlearn/"
license=('custom: Copyright 2013-2014 Lars Buitinck / University of Amsterdam and contributors')
makedepends=('git')
options=(!emptydirs)
-source=(git://github.com/larsmans/seqlearn.git)
+source=(git+https://github.com/larsmans/seqlearn.git)
md5sums=("SKIP")
+pkgver() {
+ cd "$srcdir/seqlearn"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
package_python-seqlearn-git() {
depends=('python' 'python-numpy>=1.6' 'python-scipy>=0.11' 'cython>=0.20.2')
cd "$srcdir/seqlearn"
@@ -24,5 +30,3 @@ package_python2-seqlearn-git() {
cd "$srcdir/seqlearn"
python2 setup.py install --root="$pkgdir/" --optimize=1
}
-
-# vim:set ts=2 sw=2 et: