summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0a413b2a570e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Autumn Boyhan <autumn@crisismodel.com>
+
+pkgname=python-sge
+_pkgname=sge
+pkgver=2.0.post0
+pkgrel=1
+pkgdesc="The Seclusion Game Engine, or SGE, is a general-purpose 2-D game engine."
+arch=('x86_64')
+url="https://python-sge.github.io/"
+license=('GPL3')
+depends=('python' 'python-pygame')
+makedepends=('python-setuptools')
+provides=('python-sge')
+conflicts=('python-sge')
+_name=${pkgname#python-}
+source=("https://github.com/python-sge/sge/archive/refs/tags/v${pkgver}.tar.gz")
+md5sums=('bc6363ad02da7c015d46fabb5367b2a7')
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}