summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fa8df7773ca3..5492b3a2d76d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,17 +7,22 @@
pkgbase='python-sip-pyqt4'
pkgname=('python-sip-pyqt4' 'python2-sip-pyqt4')
-pkgver=4.19.24
-pkgrel=1
+pkgver=4.19.25
+pkgrel=2
arch=('x86_64')
url='https://www.riverbankcomputing.com/software/sip/intro'
license=('custom:"sip"')
makedepends=('python' 'python2')
-source=("https://www.riverbankcomputing.com/static/Downloads/sip/$pkgver/sip-$pkgver.tar.gz")
-sha256sums=('edcd3790bb01938191eef0f6117de0bf56d1136626c0ddb678f3a558d62e41e5')
+source=("https://www.riverbankcomputing.com/static/Downloads/sip/$pkgver/sip-$pkgver.tar.gz"
+ '0001-Fix-compilation-against-Python-3.11.patch')
+sha256sums=('b39d93e937647807bac23579edbff25fe46d16213f708370072574ab1f1b4211'
+ '56ebacabe7f7fade875256ef19f835dc8ecc6bec080802403669352128059fbd')
prepare() {
mkdir -p build-pyqt4{,-py2}
+
+ cd "$srcdir"/sip-$pkgver
+ patch --strip=1 --input=../0001-Fix-compilation-against-Python-3.11.patch
}
build() {