summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1b84017bfcd7..965f2dde0be7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,27 @@
# Contributor: Andrey Mikhaylenko <neithere at gmail dot com>
pkgname=(python-slugify python2-slugify)
pkgbase=python-slugify
-pkgver=1.2.5
-pkgrel=2
+pkgver=1.2.6
+pkgrel=1
pkgdesc="A Python slugify application that handles unicode"
arch=(any)
url="https://github.com/un33k/python-slugify"
license=('BSD')
makedepends=("python-setuptools" "python2-setuptools")
source=(https://github.com/un33k/python-slugify/archive/${pkgver}.tar.gz)
-md5sums=('1d6949c2db9ba0facb42236cc6086099')
-sha256sums=('5a819e2519e9c974dbc447d11c3755850262e0bf5563808ccfdd8f4e90468319')
+md5sums=('0d2a4d8433a02fa730444bbb7a0caebb')
+sha256sums=('a360fd694bf4b78dedb224324e6c3b05682ff1b0354a95b5f78ba1108f3388f8')
package_python-slugify() {
depends=("python" "python-unidecode>=0.04.16")
+ optdepends=("python-text-unidecode: text-unidecode support")
cd "$srcdir/$pkgbase-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1
}
package_python2-slugify() {
depends=("python2" "python2-unidecode>=0.04.16")
+ optdepends=("python2-text-unidecode: text-unidecode support")
cd "$srcdir/$pkgbase-$pkgver"
python2 setup.py install --root="$pkgdir" --optimize=1
mv "$pkgdir/usr/bin/slugify" "$pkgdir/usr/bin/slugify2"