summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 13 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 43831619efc8..eb9516326997 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,22 @@
_name=smart-progress
pkgname=python-$_name
pkgver=1.0.2
-pkgrel=2
+pkgrel=3
pkgdesc='Smart progressbar with multiple backends selected depending on the environment'
arch=('any')
url="https://github.com/flying-sheep/$_name"
-license=('GPL3')
-depends=('python' 'jupyter' 'python-click')
-makedepends=('python-pip')
-source=("https://files.pythonhosted.org/packages/py3/s/$_name/${_name/-/_}-$pkgver-py3-none-any.whl")
-md5sums=('e299adff567ae9fd159745efa3bc820b')
+license=(GPL3)
+depends=(python jupyter python-click)
+makedepends=(python-build python-installer)
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('3a2ef36aa7d3846476d44fe436ad6be68bd384e3cea4655a6185bcc82a31d280')
+
+build() {
+ cd "$_name-$pkgver"
+ python -m build --wheel --no-isolation
+}
package() {
- pip install --root="$pkgdir" --ignore-installed --no-deps "$srcdir/${_name/-/_}-$pkgver-py3-none-any.whl"
+ cd "$_name-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}