summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 11 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 276a53de877a..bc77fc0e9bc1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Peter Mattern <pmattern at arcor dot de>
pkgname=python-social-auth-core
-pkgver=4.3.0
+pkgver=4.5.4
pkgrel=1
pkgdesc='Python Social Auth core component'
arch=('any')
@@ -10,21 +10,25 @@ url='https://github.com/python-social-auth/social-core'
license=('BSD')
depends=('python-six' 'python-defusedxml' 'python-pyjwt' 'python-jose' 'python-requests-oauthlib'
'python-openid' 'python-cryptography' 'python3-saml')
-makedepends=('python-setuptools')
+makedepends=(
+ 'python-build'
+ 'python-installer'
+ 'python-wheel'
+)
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
-sha256sums=('baf792268f4a928cd5f02bd538e7b6f80af493411e1ea223f0a98d50dd894d03')
+sha256sums=('0070f7d9a0eb4903de2990d6b8cd42ff5ea91f8caff83386a2f6a087ebeaa577')
build() {
cd social-core-"${pkgver}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd social-core-"${pkgver}"
- python setup.py install \
- --root "${pkgdir}" \
- --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 "${srcdir}/social-core-${pkgver}/LICENSE" \
"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ rm -rf "${pkgdir}/usr/lib/python3.11/site-packages/social_core/tests"
}