summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8817991661a9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Dan Elkouby <streetwalrus@codewalr.us>
+pkgname=python-soco
+pkgver=0.11.1
+pkgrel=1
+pkgdesc="A simple Python class that allows you to programmatically control Sonos speakers"
+arch=('any')
+url="https://github.com/SoCo/SoCo"
+license=('MIT')
+depends=('python' 'python-requests')
+options=(!emptydirs)
+source=("https://github.com/SoCo/SoCo/archive/v$pkgver.tar.gz")
+md5sums=('c0ff6775e70cea9cc26a01ad85a120ec')
+
+package() {
+ cd "$srcdir/SoCo-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm644 LICENSE.rst "$pkgdir/usr/share/licenses/$pkgname/LICENSE.rst"
+}
+
+# vim:set ts=2 sw=2 et: