summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 561b020239bf..310f57f39a97 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,16 @@
pkgbase=python-soupsieve
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}" "python2-${_pyname}")
-pkgver=1.7
+pkgver=1.7.1
pkgrel=1
pkgdesc="A modern CSS selector implementation for BeautifulSoup"
arch=('i686' 'x86_64')
url="https://facelessuser.github.io/soupsieve/"
license=('MIT')
makedepends=('python-setuptools' 'python2-setuptools')
-checkdepends=('python-pytest' 'python2-pytest' 'python2-beautifulsoup4' 'python-beautifulsoup4' 'python2-html5lib' 'python-html5lib')
+checkdepends=('python-pytest' 'python2-pytest' 'python2-beautifulsoup4' 'python-beautifulsoup4' 'python2-html5lib' 'python-html5lib' 'python2-backports.functools_lru_cache')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('2b5a9f36b55ab1b0c079e07e9926da82')
+md5sums=('92a40c3a664175949622e311cf0779bb')
prepare() {
cd ${srcdir}/${_pyname}-${pkgver}
@@ -40,7 +40,7 @@ check() {
}
package_python2-soupsieve() {
- depends=('python2>=2.7' 'python2-beautifulsoup4')
+ depends=('python2>=2.7')
cd ${srcdir}/${_pyname}-${pkgver}-py2
install -D -m644 LICENSE.md -t "${pkgdir}/usr/share/licenses/${pkgname}"
@@ -49,7 +49,7 @@ package_python2-soupsieve() {
}
package_python-soupsieve() {
- depends=('python>=3.4' 'python-beautifulsoup4')
+ depends=('python>=3.4')
cd ${srcdir}/${_pyname}-${pkgver}
install -D -m644 LICENSE.md -t "${pkgdir}/usr/share/licenses/${pkgname}"