summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 22 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b64e7edf0ab1..03e5a59aeab8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,31 @@
# Python package author: Matthew Honnibal <matt@explosion.ai>
pkgname=python-spacy-git
_origpkgname=spaCy
-pkgver=2.0.18.r8886.bbaca991
-pkgrel=3
+pkgver=2.1.0a4.r9320.0f83b98a
+pkgrel=4
pkgdesc="A free open-source library for Natural Language Processing in Python"
arch=("x86_64")
url="https://spacy.io/"
license=("MIT")
-depends=("cython"
- "python-numpy"
- "python-cymem"
- "python-preshed"
- "python-thinc"
- "python-murmurhash"
- "python-plac"
- "python-ujson"
- "python-dill"
- "python-regex"
- "python-requests"
- "python-pytest"
- "python-mock"
-)
+depends=("python-cymem"
+ "python-preshed"
+ "python-thinc"
+ "python-blis"
+ "python-murmurhash"
+ "python-wasabi"
+ "python-srsly"
+ "python-numpy"
+ "python-requests"
+ "python-jsonschema"
+ "python-regex"
+ "python-plac"
+ "cython"
+ "python-pytest"
+ "python-pytest-timeout"
+ "python-mock"
+ "flake8"
+ )
+
makedepends=('git' 'python-setuptools' 'python-wheel')
provides=('python-spacy')
conflicts=('python-spacy')
@@ -35,7 +40,7 @@ prepare() {
pkgver() {
cd "$_origpkgname"
- printf "%s.r%s.%s" "$(cat spacy/about.py | grep -i version | grep -v '#' | cut -d "'" -f2 | head -n 1)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ printf "%s.r%s.%s" "$(cat spacy/about.py | grep -i version | grep -v '#' | cut -d '"' -f2 | head -n 1)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {