summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD79
1 files changed, 41 insertions, 38 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 03e5a59aeab8..02ae11559e59 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,50 +1,53 @@
-# Maintainer: DanManN <dnahimov@gmail.com>
-# Python package author: Matthew Honnibal <matt@explosion.ai>
+# Maintainer: Philip Goto <philip.goto@gmail.com>
+# Contributor: DanManN <dnahimov@gmail.com>
+
pkgname=python-spacy-git
-_origpkgname=spaCy
-pkgver=2.1.0a4.r9320.0f83b98a
-pkgrel=4
-pkgdesc="A free open-source library for Natural Language Processing in Python"
-arch=("x86_64")
+pkgver=2.3.0.r136.g3851300e8
+pkgrel=1
+pkgdesc="Free open-source library for Natural Language Processing in Python"
+arch=(i686 x86_64 armv7h aarch64)
url="https://spacy.io/"
-license=("MIT")
-depends=("python-cymem"
- "python-preshed"
- "python-thinc"
- "python-blis"
- "python-murmurhash"
- "python-wasabi"
- "python-srsly"
- "python-numpy"
- "python-requests"
- "python-jsonschema"
- "python-regex"
- "python-plac"
- "cython"
- "python-pytest"
- "python-pytest-timeout"
- "python-mock"
- "flake8"
- )
-
-makedepends=('git' 'python-setuptools' 'python-wheel')
-provides=('python-spacy')
-conflicts=('python-spacy')
-source=("git+https://github.com/explosion/$_origpkgname.git")
+license=(MIT)
+depends=(
+ cython
+ python-catalogue
+ python-cymem
+ python-murmurhash
+ python-numpy
+ python-pathlib
+ python-plac
+ python-preshed
+ python-regex
+ python-requests
+ python-srsly
+ python-thinc
+ python-tqdm
+ python-ujson
+ python-wasabi
+)
+makedepends=(git python-wheel cython)
+provides=(python-spacy)
+conflicts=(python-spacy)
+source=("git+https://github.com/explosion/spaCy.git")
md5sums=('SKIP')
+
prepare() {
- cd "$_origpkgname"
- git checkout $(curl https://api.github.com/repos/explosion/$_origpkgname/releases | grep tag_name | cut -d '"' -f4 | head -n 1)
+ cd spaCy
}
pkgver() {
- cd "$_origpkgname"
- printf "%s.r%s.%s" "$(cat spacy/about.py | grep -i version | grep -v '#' | cut -d '"' -f2 | head -n 1)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd spaCy
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd spaCy
+ python setup.py build
}
package() {
- cd "$_origpkgname"
- python setup.py install --root="${pkgdir}/" --optimize=1
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd spaCy
+ python setup.py install --skip-build --root="${pkgdir}" --optimize=1
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}