summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 975f58cc2bdf..b64e7edf0ab1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Python package author: Matthew Honnibal <matt@explosion.ai>
pkgname=python-spacy-git
_origpkgname=spaCy
-pkgver=2.0.18.r8888.ae5601be
-pkgrel=2
+pkgver=2.0.18.r8886.bbaca991
+pkgrel=3
pkgdesc="A free open-source library for Natural Language Processing in Python"
arch=("x86_64")
url="https://spacy.io/"
@@ -22,12 +22,17 @@ depends=("cython"
"python-pytest"
"python-mock"
)
-makedepends=("python-wheel")
+makedepends=('git' 'python-setuptools' 'python-wheel')
provides=('python-spacy')
conflicts=('python-spacy')
source=("git+https://github.com/explosion/$_origpkgname.git")
md5sums=('SKIP')
+prepare() {
+ cd "$_origpkgname"
+ git checkout $(curl https://api.github.com/repos/explosion/$_origpkgname/releases | grep tag_name | cut -d '"' -f4 | head -n 1)
+}
+
pkgver() {
cd "$_origpkgname"
printf "%s.r%s.%s" "$(cat spacy/about.py | grep -i version | grep -v '#' | cut -d "'" -f2 | head -n 1)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"