summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 9 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 515a5479a750..5e11704c863c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
pkgbase=python-sphinx-asdf
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}")
-pkgver=0.1.4
-pkgrel=3
+pkgver=0.2.1
+pkgrel=1
pkgdesc="Sphinx plugin for generating documentation from ASDF schemas"
arch=('any')
url="https://github.com/asdf-format/sphinx-asdf"
@@ -16,12 +16,12 @@ makedepends=('python-setuptools-scm'
checkdepends=('python-pytest'
'python-sphinx'
'python-asdf'
- 'python-mistune=0.8.4')
+ 'python-mistune>=3')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-sha256sums=('4f79db5412d7d1cd2649ce5fa42160e54942758beba2de30605a74f12a23365c')
+sha256sums=('50c097b3a642d9f9fc8dad5947e35130e36718896fa64dd1eeafd175527609f5')
get_pyver() {
- python -c 'import sys; print(".".join(map(str, sys.version_info[:2])))'
+ python -c "import sys; print('$1'.join(map(str, sys.version_info[:2])))"
}
build() {
@@ -34,21 +34,18 @@ check() {
cd ${srcdir}/${_pyname}-${pkgver}
ln -rs ${srcdir}/${_pyname}-${pkgver}/${_pyname/-/_}*egg-info \
- build/lib/${_pyname/-/_}-${pkgver}-py$(get_pyver).egg-info
- PYTHONPATH="build/lib" pytest || warning "Tests failed"
+ build/lib/${_pyname/-/_}-${pkgver}-py$(get_pyver .).egg-info
+ PYTHONPATH="build/lib" pytest || warning "Tests failed" # -vv -l -ra --color=yes -o console_output_style=count
}
package() {
depends=('python-asdf'
'python-astropy>=5.0.4'
- 'python-graphviz'
- 'python-matplotlib'
- 'python-myst-parser'
- 'python-mistune=0.8.4'
+ 'python-mistune>=3'
+ 'python-packaging'
'python-sphinx-astropy'
'python-sphinx-bootstrap-theme'
'python-sphinx_rtd_theme'
- 'python-sphinx-inline-tabs'
'python-toml')
cd ${srcdir}/${_pyname}-${pkgver}