summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD48
1 files changed, 26 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a134c5e3c421..3bbea13f40a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,43 @@
# Maintainer: Ben Wolsieffer <benwolsieffer@gmail.com>
-pkgname=python-sphinx-autobuild
+_py_pkgname=sphinx-autobuild
+pkgname=python-${_py_pkgname}
pkgver=0.7.1
-pkgrel=1
+pkgrel=2
pkgdesc="Watch a Sphinx directory and rebuild the documentation when a change is detected. Also includes a livereload enabled web server."
arch=('any')
url="https://github.com/GaretJax/sphinx-autobuild"
license=('MIT')
-groups=()
depends=(
'python-sphinx'
- 'python-watchdog>=0.7.1'
- 'python-argh>=0.24.1'
- 'python-pathtools>=0.1.2'
- 'python-yaml>=3.10'
- 'python-tornado>=3.2'
- 'python-port-for=0.3.1'
- 'python-livereload>=2.3.0'
-)
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=(!emptydirs)
-install=
-source=(
- https://files.pythonhosted.org/packages/source/s/sphinx-autobuild/sphinx-autobuild-$pkgver.tar.gz
+ 'python-watchdog'
+ 'python-argh'
+ 'python-pathtools'
+ 'python-yaml'
+ 'python-tornado'
+ 'python-port-for'
+ 'python-livereload'
)
+checkdepends=('python-pytest' 'python-mock')
+source=("https://files.pythonhosted.org/packages/source/${_py_pkgname::1}/${_py_pkgname}/${_py_pkgname}-${pkgver}.tar.gz")
sha256sums=('66388f81884666e3821edbe05dd53a0cfb68093873d17320d0610de8db28c74e')
+build() {
+ cd "${srcdir}/${_py_pkgname}-${pkgver}"
+ python setup.py build
+}
+
+check() {
+ cd "${srcdir}/${_py_pkgname}-${pkgver}"
+
+ py.test
+}
+
package() {
- cd "$srcdir/sphinx-autobuild-$pkgver"
+ cd "${srcdir}/${_py_pkgname}-${pkgver}"
- python setup.py install --root="$pkgdir/" --optimize=1
+ python setup.py install --root="${pkgdir}/" --optimize=1
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-# vim:set ts=2 sw=2 et:
+# vim:set ts=4 sw=4 et: