summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 60eb41a7689a..c3021ab3ac1a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
upstream_name=hawkmoth
aur_name=python-sphinx-hawkmoth
pkgname=$aur_name-git
-pkgver=0.8.0.69r.g4bebfe2
+pkgver=0.12.0.0r.g9a77f67
pkgrel=1
pkgdesc='Sphinx autodoc C extension'
arch=('i686' 'x86_64')
url='https://github.com/jnikula/hawkmoth'
license=('BSD2')
depends=('python-sphinx' 'clang')
-makedepends=('python-build' 'python-install' 'python-wheel')
+makedepends=('python-build' 'python-installer' 'python-wheel')
provides=($aur_name)
conflicts=($aur_name)
source=('git+https://github.com/jnikula/hawkmoth')
@@ -29,6 +29,6 @@ build() {
package() {
cd $srcdir/$upstream_name
- python -m install --optimize=1 --destdir="$pkgdir" dist/*.whl
+ python -m installer --compile-bytecode=1 --destdir="$pkgdir" dist/*.whl
install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}