summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d32da6bb91bb..2069250d879f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
upstream_name=hawkmoth
aur_name=python-sphinx-hawkmoth
pkgname=$aur_name-git
-pkgver=latest
-pkgrel=3
+pkgver=0.7.0.0r.g69cde0b
+pkgrel=1
pkgdesc='Sphinx autodoc C extension'
arch=('i686' 'x86_64')
url='https://github.com/jnikula/hawkmoth'
@@ -15,6 +15,11 @@ conflicts=($aur_name)
source=('git+https://github.com/jnikula/hawkmoth')
md5sums=('SKIP')
+pkgver() {
+ cd "$upstream_name"
+ git describe --long | sed 's/v\(.*\)\([^-]*-g\)/\1r\2/;s/-/./g'
+}
+
package() {
install -D -m644 $srcdir/$upstream_name/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
cd $srcdir/$upstream_name