summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 71150f9d89d1..f0029a331210 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgbase=python-sphinx
pkgname=('python-sphinx' 'python2-sphinx')
-pkgver=1.5.5
+pkgver=1.6.1
pkgrel=1
arch=('any')
@@ -40,11 +40,12 @@ checkdepends=(
'python-requests' 'python2-requests'
'python2-pytest' 'python-pytest'
'python2-enum34'
+ 'python-sphinxcontrib-websupport' 'python2-sphinxcontrib-websupport'
)
source=("https://pypi.org/packages/source/S/Sphinx/Sphinx-$pkgver.tar.gz")
-md5sums=('f9581b3556df9722143c47290273bcf8')
+md5sums=('26cb1cdca7aa4afc8c925d926b6268e7')
prepare() {
# souce duplication is required because makefile modify source code
@@ -94,7 +95,8 @@ package_python-sphinx() {
'python-imagesize'
'python-requests'
)
- optdepends=('texlive-latexextra: for generation of PDF documentation')
+ optdepends=('texlive-latexextra: for generation of PDF documentation'
+ 'python-sphinxcontrib-websupport: Python API to easily integrate Sphinx documentation into Web applications')
cd Sphinx-$pkgver
python setup.py install --root="$pkgdir" --optimize=1
@@ -116,7 +118,8 @@ package_python2-sphinx() {
'python2-imagesize'
'python2-requests'
)
- optdepends=('texlive-latexextra: for generation of PDF documentation')
+ optdepends=('texlive-latexextra: for generation of PDF documentation'
+ 'python2-sphinxcontrib-websupport: Python API to easily integrate Sphinx documentation into Web applications')
cd Sphinx-${pkgver}2
python2 setup.py install --root="$pkgdir" --optimize=1