summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD69
1 files changed, 56 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b6153aa5bae9..9728f12efc8b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,68 @@
-# Maintainer: Tim Schumacher <timschumi@gmx.de>
+# Maintainer: zoorat <zoorat [at] protonmail [dot] com>
+# Maintainer: Amin Vakil <info AT aminvakil DOT com>
+# Contributor: txtsd <aur.archlinux@ihavea.quest>
+# Contributor: Tim Schumacher <timschumi@gmx.de>
# Contributor: Felix Yan <felixonmars@archlinux.org>
# Contributor: Gordian Edenhofer <gordian.edenhofer[at]yahoo[dot]de>
pkgname=python-spotdl
-pkgver=3.1.2
-pkgrel=1
-pkgdesc="Download songs from YouTube using Spotify song URLs or playlists with albumart and meta-tags."
+pkgver=4.2.5
+pkgrel=3
+
+pkgdesc='Download your Spotify playlists and songs along with album art and metadata (from YouTube if a match is found).'
arch=('any')
+url='https://github.com/spotDL/spotify-downloader'
+# url='https://spotdl.readthedocs.io/en/latest/'
license=('MIT')
-url="https://github.com/spotDL/spotify-downloader"
-depends=('python-setuptools' 'ffmpeg' 'python-spotipy' 'python-pytube3' 'python-tqdm' 'python-rapidfuzz' 'python-requests' 'python-mutagen')
-source=("https://pypi.io/packages/source/s/spotdl/spotdl-$pkgver.tar.gz")
-sha512sums=('40a3d21967566b865fd8838937c72a0b8b4864a02369d4dd907216d529f5d37dcf0a2d0ecf22ea1773f1578369f05e898ce4404be8ac2b5d74dbe2d46f1255a7')
+# https://github.com/spotDL/spotify-downloader/blob/master/pyproject.toml
+depends=(
+ 'ffmpeg'
+ 'python'
+ 'python-bandcamp-api'
+ 'python-beautifulsoup4'
+ 'python-dacite'
+ 'python-demjson3'
+ 'python-fastapi'
+ 'python-mutagen'
+ 'python-platformdirs'
+ 'python-pydantic'
+ 'python-pykakasi'
+ 'python-pytube'
+ 'python-rapidfuzz'
+ 'python-requests'
+ 'python-rich'
+ 'python-soundcloud-v2'
+ 'python-slugify'
+ 'python-spotipy'
+ 'python-syncedlyrics'
+ 'python-typing-extensions'
+ 'python-ytmusicapi'
+ 'uvicorn'
+ 'yt-dlp'
+)
+makedepends=('python-build' 'python-installer' 'python-wheel' 'python-poetry-core')
+checkdepends=('python-pytest-asyncio' 'python-pytest-mock')
+provides=("$pkgname" 'spotdl')
+options=(strip emptydirs zipman)
+
+source=("https://github.com/spotDL/spotify-downloader/archive/refs/tags/v$pkgver.zip")
+b2sums=('bad96199ae1768e85efbc992603b911b3967624b26b65e1e3d7de0cbdcba193bbc04f64210c390017cb8b08d4a277907ebf8d9236e5247a2e56e4e2d50fb8c1b')
+
+# Document: https://wiki.archlinux.org/title/Python_package_guidelines
build() {
- cd spotdl-$pkgver
- python setup.py build
+ cd spotify-downloader-$pkgver
+ # https://github.com/python-poetry/poetry/issues/5547
+ python -m build --wheel --no-isolation
}
-package() {
- cd spotdl-$pkgver
- python setup.py install --root="$pkgdir" --optimize=1
+check() {
+ cd spotify-downloader-$pkgver
+ pytest || echo 'Tests failed!'
}
+package() {
+ cd spotify-downloader-$pkgver
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -vDm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}