summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..24e603c8f48e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+pkgbase='python-stargen'
+pkgname=('python-stargen')
+_module='stargen'
+pkgver=0.8.5
+pkgrel=1
+pkgdesc="Framework for wordlist generation, combination and expansion"
+url="https://github.com/codeswhite/stargen"
+depends=('python')
+makedepends=('python-setuptools')
+optdepends=('crunch: Generating wordlists programmatically')
+license=('MIT')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
+sha256sums=("c516546005510628638347870a972273c4297dfe38d0ddb83007281317061873")
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}