summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..27c0dcbb3312
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+pkgname=python-stateutil
+pkgver=1.4.0
+pkgrel=1
+pkgdesc="A collection of state machine utilities"
+arch=(any)
+url="https://bitbucket.org/daycoder/stateutil"
+license=('custom:PSF')
+makedepends=('python-setuptools')
+depends=('python')
+source=("https://pypi.io/packages/source/s/stateutil/stateutil-$pkgver.tar.gz")
+sha512sums=('SKIP')
+
+check() {
+ # Not included in release tarball
+ cd stateutil-$pkgver
+ # python test_stateutil.py
+}
+
+package() {
+ cd stateutil-$pkgver
+ python setup.py install --root="$pkgdir/" --optimize=1
+}