summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d1edf9be6e09..c230cf94b99e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,25 @@
# Maintainer: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
pkgname=python-stomp.py
-_libname=${pkgname/python-/}
-pkgver=7.0.0
+_libname=stomp_py
+pkgver=8.1.2
pkgrel=1
pkgdesc="Python STOMP client, supporting versions 1.0, 1.1 and 1.2 of the protocol"
arch=(any)
url="https://github.com/jasonrbriggs/stomp.py"
-license=(Apache)
-depends=(python)
+license=(Apache-2.0)
+depends=(python python-docopt python-websocket-client)
+makedepends=(python-setuptools python-wheel python-build python-installer python-poetry)
source=(https://files.pythonhosted.org/packages/source/${_libname:0:1}/$_libname/$_libname-$pkgver.tar.gz)
+sha256sums=('b56e62da090863cc65e5fbf832230318cd53e99dc777de19ecb04e83914f1371')
build() {
cd "$srcdir"/$_libname-$pkgver
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "$srcdir"/$_libname-$pkgver
- python setup.py install -O1 --skip-build --root="$pkgdir"
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm0644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
-
-sha256sums=('fb301f338292b1b95089c6f1d3a38a9dd8353a5ff3f921e389dfa5f9413b5a8a')